d) Mengganti IP address Komputer

Masing-masing komputer yang digambarkan pada topologi di atas masih menggunakan IP address satu subnet, yaitu 192.168.100.0. Akan lebih baik lagi jika kita mengubah konfigurasi IP address-mnya dengan yang lain. Sehingga percobaanya menjadi lebih menarik. Sebuat saja konfigurasi Skenario-3a. Perhatikan tabel berikut dan ubahlah IP address komputer sesuai tabel.

HostnameIP AddressNetmaskSubnet
PC0192.168.10.1255.255.255.0192.168.10.0
PC1192.168.10.2255.255.255.0
PC2192.168.20.1255.255.255.0192.168.20.0
PC3192.168.20.2255.255.255.0
PC4192.168.30.1255.255.255.0192.168.30.0
PC5192.168.30.2255.255.255.0

sekarang masing-masing komputer anggota VLAN sudah dikelompokkan dalam subnet yang berbeda.

e. Menambah Router

Topologi
Topologi

Kita akan menambahkan sebuah router seperti gambar topologi diatas. Router ini akan digunakan untuk menghubungkan ketiga VLAN. Pilihlah sebuah port switch dan hubungkan kabel dengan port ethernet router. Perhatikan gambar router on a stick diatas. Seperti itulah topologi yang akan kita buat.

Misalkan saja port fa0/7 telah terhubung dengan router. Ketikkan perintah berikut :

Switch#config t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#int fa0/7
Switch(config-if)#switchport mode trunk
Switch(config-if)#exit

Kemudian melakukan konfigurasi pada router. pada router terdapat dua buath interface, fa0/1 digunakan untuk jalur ke luar (misal Internet), sedangkan interface fa0/0 digunakan untuk menghubungkan switch.

Karena VLAN berjumlah tiga buah maka kita harus membuat subinterface. Setiap subinterface akan diberi IP address yang berbeda. Masing-masing VLAN akan terhubung dengan subinterface tersebut. Perintah untuk membuat subinterface adalah interface nama_subinterface.id_vlan, misalnya:

Router#config t
Router(config)#int fa0/0
Router(config-if)#no shut
Router#config t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int fa0/0.2

Kemudian kita lihat apakan interface fa0/0 status UP.

Router#sh ip int b
Interface              IP-Address      OK? Method Status                Protocol
 
FastEthernet0/0        unassigned      YES unset  up                    up
 
FastEthernet0/0.2      192.168.10.100  YES manual up                    up
 
FastEthernet1/0        unassigned      YES unset  administratively down down
 
Serial2/0              unassigned      YES unset  administratively down down
 
Serial3/0              unassigned      YES unset  administratively down down
 
FastEthernet4/0        unassigned      YES unset  administratively down down
 
FastEthernet5/0        unassigned      YES unset  administratively down down

Supaya subinterface berjalan maka router harus mendukung protokol VLAN trunking 802.1q. Untuk melakukan enkapsulasi 802.1q gunakan perintah encapsulation dot1q id_vlan, misal :

Router(config-subif)#encapsulation dot1q 2

Kemudian setiap VLAN harus mengetahui IP address gateway, yaitu IP subinterface yang terhubung dengan VLAN tersebut. Perhatikan tabel berikut.

HostnameIP AddressIP GatewaySubnet
PC0192.168.10.1192.168.10.100192.168.10.0
PC1192.168.10.2
PC2192.168.20.1192.168.20.100192.168.20.0
PC3192.168.20.2
PC4192.168.30.1192.168.30.100192.168.30.0
PC5192.168.30.2

Setelah mengetahui IP address gateway setiap komputer, segeralah memberikan IP address gateway yang sesuai untuk masing-masing komputer.

Perintah untuk mengaktifkan dan menghubungkan subinterface router dengan VLAN 2 sebagai berikut :

Router(config)#interface fa0/0.2
Router(config)#encapsulation dot1q 2
Router(config-subif)#ip address 192.168.10.100 255.255.255.0

Test dari PC0 dan PC1. Ping ke IP address subinterface fa0/0.2. Bisa juga mencoba ping dari router ke IP address PC0 dan PC1.

Router#ping 192.168.10.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 0/0/3 ms

Selanjutnya konfigurasi subinterface untuk VLAN 3 dan 4.

Router#config t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int fa0/0.3
Router(config-subif)#encapsulation dot1q 3
Router(config-subif)#ip address 192.168.20.100 255.255.255.0

Router(config-subif)#int fa0/0.4
Router(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.4, changed state to up
Router(config-subif)#encapsulation dot1q 4
Router(config-subif)#ip address 192.168.30.100 255.255.255.0
Perlu di ingat bahwa setelah perintah encapsulation dot1q adalah ID VLAN didaftarkan di switch

cek tabel routing :

Router>en
Router#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.10.0/24 is directly connected, FastEthernet0/0.2
C    192.168.20.0/24 is directly connected, FastEthernet0/0.3
C    192.168.30.0/24 is directly connected, FastEthernet0/0.4

Menyimpan konfigurasi :

Router#copy running-config startup-config
Destination filename [startup-config]? 
Building configuration...
[OK]

Switch>en
Switch#copy running-config startup-config
Destination filename [startup-config]? 
Building configuration...