b. Konfigurasi switch

Untuk saat ini kit ahanya perlu mengubah hostname masing-masing switch. Pastikan kita sudah memasuki switch via port Console. Kemudian dari HyperTerminal ketikkan perintah berikut ini.

Subnet 1

Switch>enable
Switch#configure terminal
Switch(config)#hostname Sjupiter
Sjupiter(config)

Subnet2

Switch>enable
Switch#configure terminal
Switch(config)#hostname Sleo
Sleo(config)

Untuk dicoba

Dari masing-masing switch cobalah melakukan ping ke setiap komputer. Apakah berhasi ?

c. Konfigurasi router

Berikutnya melakukan konfigurasi router. Agar lebih mudah memahaminya.

Subnet1

Menentukan hostname

Router>enable
Router#configure terminal
Router(config)#hostname Sjupiter
Rjupiter(config)

Menentukan IP address ethernet

Rjupiter(config)#interface FastEthernet0/0
Rjupiter(config-if)#ip address 192.168.1.100 255.255.255.0
Rjupiter(config-if)#no shut
Rjupiter(config-if)exit

Menentukan IP address serial

Rjupiter(config)#interface Serial0/0
Rjupiter(config-if)#ip address 172.16.1.100 255.255.0.0
Rjupiter(config-if)#no shutdown
Rjupiter(config-if)#clock rate 128000

Kita menggunakan port serial sebagai DCE, sehingga perlu ditentukan clock rate. Bisa memilih clock rate yang lebih tinggi atau lebih rendah, misal 9600, 19200, 38400, dan sebaginya.

Subnet2

Menentukan hostname

Router>enable
Router#configure terminal
Router(config)#hostname Rleo
Rleo(config)#

Menentukan IP address ethernet

Rleo(config)#interface Serial2/0
Rleo(config-if)#ip address 10.10.10.100 255.255.0.0
Rjupiter(config-if)#no shutdown
Rjupiter(config-if)#exit

Menentukan IP address serial

Rjupiter(config)#interface Serial2/0
Rjupiter(config-if)#ip address 172.16.1.200 255.255.0.0
Rjupiter(config-if)#no shutdown
Rjupiter(config-if)#clock rate 128000

Untuk dicoba

Sampai dengan tahap ini , lakukan ping :

  • dari Rjupiter ke jupiter dan sebaliknya
  • dari Rleo ke leo dan sebaliknya
  • dari jupiter ke leo dan sebalinya

Jika perintah-perintah yang diketikkan benar dan kabel network sudah terpasang dengan benar juga, maka masing-masing router sudah bisa mem-ping ke IP komputer yang ada di subnetnya. Bahkan setiap komputer juga seharusnya sudah bisa menge-ping ke IP address interface serial router yang satu subnet dengannya.

Contoh ouput perintah ping dari Rjupiter ke jupiter:

Rjupiter#ping 192.168.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/1/3 ms

Saat ini kita belum menentukan IP address gateway pada Rjupiter maupun Rleo. Juga belum ada tabel routing. Sehingga kedua subnet tersebut belum dapat saling berkomunikasi. Langkah-langkahnya sebagai berikut.

Subnet1

Router pada subnet 1 juga ingin mencapai network 10.0.0.0 harus melalui IP address 172.16.1.200. Sehingga IP ini merupakan gateway bagi router.

Menentukan IP address gateway

Rjupiter?enable
Rjupiter#configure terminal
Rjupiter(config)#ip route 10.0.0.0  255.0.0.0  172.16.1.200

Mengamati daftar route

Rjupiter#show ip route
Rjupiter#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

S    10.0.0.0/8 [1/0] via 172.16.1.200
C    172.16.0.0/16 is directly connected, Serial2/0
C    192.168.1.0/24 is directly connected, FastEthernet0/0

Subnet2

Router pada subnet 2 jika ingin mencapai network 192.168.1.0 harus melalui IP address 172.16.1.100. Sehingga IP ini merupakan gateway bagi router.

Menentukan IP address gateway

Rleo>enable
Rleo#configure terminal
Rleo(config)#ip route 192.168.1.0 255.255.255.0  172.16.1.100
Rleo#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, FastEthernet0/0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Serial2/0
S    192.168.1.0/24 [1/0] via 172.16.1.100

Untuk dicoba

Lakukan ping dari jupiter ke leo. Apakah berhasil?